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WHAT IS EPUB?
The International Digital Publishing Forum (IDPF) is the 

Trade and Standards Organization for the Digital Publishing Industry. Epub is the free and open 
e-book standard offered by the IDPF. 
International Digital Publishing Forum
There two versions of ePub being used today - versions 2.0.1 and 3.0. Version 3 is in the 
experimental stage and is capable of new features. iBooks Author is loosely based on the version 3 
standards being developed. You can also create ePub books in iWorks Pages application which uses 
the version 2 standards.

ePUB (version 2) is essentially a text format - and is most useful when the majority and most 
important parts of the document are in text form. ePub doesn't fully support layout extras like 
columns, image effects, floating images and tables. It is designed for content that is flowable.

The ePUB format can be read on many devices like the Barnes and Noble Nook, the Sony eReader - 
and the iBooks app on the iPad, iPhone and iPod. Amazon has it’s own proprietary format for the 
Kindle.

The application Pages (version 4.1 and above) from the iWork suite of apps now has ePUB export 
capabilities. Recently, Apple announced the iBooks Author app in conjunction with the release of the 
new Textbooks category in iBooks. You need the Lion OS (10.7.2 or above) to use Author. It allows 
anyone to create beautiful multi-touch books for the iPad that include galleries, video, interactive 
pieces and 3D objects. ...And it’s free!

IBOOKS AUTHOR

There are limitations to the ePub platform because it was originally developed for books with mostly 
text. To make interactive magazines and books with digital content in them, you had to use software 
like Adobe’s InDesign, and pay a lot of money to have your book published for the iPad. Now, there is 
iBooks Author. 

As I mentioned before - iBooks Author is free in the App store on your Mac, but there are some things 
you need to know about using it. Apple’s license agreement states that if you use the Author software, 

Tip: Download the free textbook from the iBookstore, LIfe on Earth, to see the 
possibilities of what can be created with iBooks Author.
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the only place you can sell your book is in the Apple iBookstore. The books that you create can only 
be viewed on an iPad - not on any other readers like Kindles or Nooks. If you choose to offer your 
books for free, they can be shared in the .ibook format that can be loaded into iTunes and synced 
with an iPad.

Getting Started: The Toolbar, Palettes and Templates
If you have used the iWork apps like Pages 
and Keynote, Author will be familiar to you. 

The toolbar looks a lot like the Pages and 
Keynote toolbars, but I suggest you add the 
Lock and Un-lock icons and also the Style 
icon for the best workflow. To customize the 
toolbar, go to View>Customize Toolbar.  
Simply drag the icons onto the toolbar 
where they will work for you. 

Familiar palettes are available such as the 
Inspector, Colors and Fonts palettes. You 
will use the Inspector frequently for text, 
image wrapping and widget layout.

When you open Author, the first step is 
choosing a professionally designed template. There are six to choose from. Each template will have 
all the pieces necessary to make a successful iBook.

There are many designers on the Web who are willing to sell you more templates for iBooks Author - 
some are even free. If you search Mac App Store for Author, you will find 10 free templates for iBook 
Author that you can download. 

Just like Pages and Keynote, you can also edit existing templates, and create your own new ones for 
your iBooks.

Parts of an iBook
Book Title is the cover of the book. This is what will appear in 
the iBookstore and on the Bookshelf on the iPad. You can add 
your own images and text to design your cover.

Intro Media is where you can add an introductory image or 
video that viewer will see the first time they open the book on 
an iPad. You can leave this empty - the book will open to the 
Table of Contents.

The Table of Contents is automatically generated as you add 
and delete content in your iBook. You can customize the table 
of contents, too. I have found that viewing the table of contents 
in landscape view on the iPad displays a blank right-hand 
page. Adding an image there looks much better.
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Glossary is available to add terms throughout your book that readers can tap for the definition of a 
word. Leaving the glossary blank is okay - it won’t appear in your published book.

Chapters and sections are where you add the contents of your book. A section is a distinct part of 
your chapter that can contain main text, copyright, a forward, etc. The default is to number chapters 
AND sections relative to the book. You can go Layout > Numbering in the Inspector to set your 
sections to be numbered relative to the chapter instead. You can also turn off numbering for chapters 
and sections altogether.
Tip: Many short chapters work better than long ones in iBooks.

Adding Content
As you add content to a chapter or section, new pages are automatically added for text flow as 
needed. You can also add pages as you go and fill them as you wish. Chapters and sections can be 
duplicated of you have made several layout changes so you don’t have to make the same changes 
for every chapter. Author will automatically number pages.

Layouts
Author provides several layouts for chapters, sections and pages. Click 
on the downward triangle next to them in the sidebar. Each template has 
different layouts. 

Note: If you change the layout of the main chapter pages, you will mess 
up how the TOC pages will look. Click on the chapter page and then on 
the TOC icon to see how it will look. If you have altered the chapter 
layout page, you will see a blank space where an image will go. If you 
add an image there, it will appear on every TOC page.

Text
All text must be in a text box. The built in layouts provide text boxes filled with placeholder text that 
you can paste over or type in to replace. New pages are added whenever any text overflows the 
page. You can add custom text boxes that aren’t part of the main text flow, but you can’t link text 
boxes to one another for text flow. 
Paragraph and character styles are available in a styles drawer just as they are in Pages. By default, 
the Styles icon is not in the toolbar; add it when you customize the toolbar.

Importing
You can import a Pages or Word document into your book as it’s own chapter or section by going to 
the Insert menu. When you import a document, the paragraph and character styles are also imported. 
Of course, you can copy and paste from any text document into Author.

Inserting Media and Other Objects
An object is any item you place on a page: text boxes, images, charts, shapes and widgets. Like the 
Pages app, objects can float on a page and text flows around it, or it can be inline with text with the 
object moving as the text moves. Objects can also be anchored to a specific spot on a page in Author. 
If you used Pages to make an ePub document, all of your objects had to be inline. With Author, they 
can float or anchor too, so you can place them precisely where you want them. 
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Drag an object onto your page to add it, or go to Insert > Choose. If you can’t add an object, it is in a 
format that Author does not support. The template you chose also has placeholder images. If you 
drag your image into a placeholder, it will retain the styling of the placeholder.

Supported File Formats
• Images: .jpg, .png, and .gif
• Video: .m4v (H.264 encoded – best to export with Quicktime Player in iPod Touch and iPhone 

format)
• Audio: m4a
Almost all objects can be placed onto your page simply by dragging them. Video and audio files must 
be placed within the Media widget, but if you drag a video or audio file onto your page, the widget will 
automatically be created around it.
Once placed on your page, objects can be manipulated by using the Inspector. Use wrapping, picture 
frames, drop shadows, etc. to make your images and other objects stand out. 

Photos and Images
Once you place images on your page, you can drag to move it and resize 
it by dragging on the selections handles. You can also crop an image by 
masking it. Select the image and go to Format > Image > Mask or Mask 
with Shape.
To adjust brightness, contrast, saturation, etc., go to View > Show Adjust 
Image.

Hyperlinks and Bookmarks
You can highlight text and add links to webpages, for an email address, to 
bookmarks and figures. Adding links to bookmarks and figures are a way 
to add additional navigation to 
your ebook. 

To add a bookmark, the first step is to 
highlight text on the page that you want 
to link to, and create the bookmark from 
the Bookmark tab in the Link Inspector. 
Just click the plus sign to add the 
bookmark to the list. The next step is to 
highlight the text on a different page 
that you want to use for the link to the 
bookmark, then find the bookmark in the list.

You can also simply link to what Author calls a ‘figure’ on a page. As you add 
objects to the pages of your book, Author makes a list of (some) of them. You can 
then filter the list of figures by diagram, figure, gallery, illustration, image, 
interactive, movie, and review in the entire book or by chapter. In my experience 
though, not every object that I added to my pages appear in the figure list. 
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Adding Widgets
Widgets are the way to add interactive objects to your 
iBook. Click on the Widget icon in the toolbar to open the 
widget choices.  Once widgets are placed on a page, the 
Widget Inspector will offer more options. You can have a 
Title or Caption or both, and choose weather or not to have 
the widget theme background visible. Apple has provided 7 
widgets for you:

Gallery is a way to create a sequence of images with 
captions that the viewer can flick through. This is the 
widget to use when you have several images to add to the 
book without taking up many pages to lay them out. You 

can drag a group of images that you have selected in the Finder, drag them in from 
the Internet, or click the +sign in the Interaction tab in the Widget Inspector to choose the image(s) 
from your computer. 

Media is the way to insert a video or audio file onto your page. Make sure they are in the right format. 
The Media widget will automatically add the controls for your video or audio clip. You can view the 
movie within Author by using the controls within the Widget Inspector. This is also where you can set 
the poster frame of a video that will display on the page until the viewer clicks the play button. If you 

wish, videos can be set to be viewed only in full screen mode, and can be set 
to loop continuously.

Review is a widget that enables you to add an interactive 
multiple choice or drag to target quiz within your book. 
There are six question styles: text multiple choice, 2 text 
multiple choice with space for an image, multiple choice with 
images and no text, dragging labels to a target image and 
dragging small images to a larger image.
Note that the quiz will not appear on the page in portrait 
view on the iPad, and make sure your audience realizes 
that they must check their answers before moving to the 

next question, or the score will show that their answers were wrong.
Keynote is the widget to use when you want to add a 
Keynote project. You might want to add directions in your 
keynote such as “touch here” to aid in navigation on the iPad.
Insert the widget onto your page and place it where you want it. If you have 
Keynote version 5.1.1 (iWork 09), simply drag the .key file into the widget on 
your page. If you have an earlier version of Keynote, export the files to HTML 
into a folder on your desktop, and drag the whole folder into the Keynote 
widget. Not all transitions and builds will work in Author. The dissolve transition 
will be used if they don’t work. 

More information about builds and transitions here…
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Interactive Image allows you to put an image in your 
iBook and add hotspots to it with captions and zoom 
levels. This is a great widget for a complex image. You 
can label parts of an image, and choose the zoom level 
to determine what viewers will see when they click on 
the label. Text describing that part of the image can 
appear as a pop-up bubble, or in a sidebar over the 
image. Add and edit labels within the widget Inspector.

3D adds a 3D open standard file to your page that 
viewers can see from all angles. Special software is 
required to make 3D images. Google SketchUp and Adobe AfterEffects are two applications. You can 
find 3D illustrations by others in SketchUp’s 3D Warehouse. (sketchup.google.com/3dwarehouse)

HTML is a widget that inserts objects that you create on your own using the Dashcode app that is/can 
be installed on your Mac. Widgets can also be created and exported for use in Author by third party 
applications such as Hype and Adobe Edge. 

Photo Zoom:
One of the coolest things about an interactive ebook is the ability to display an image in full size just 
by tapping it. However, just placing an image on a page doesn’t make it interactive. To be interactive, 
it must be in a widget - but using the gallery widget isn’t a good solution for a single image, and 
neither is the interactive image widget.
To make an image zoom, click on the image on your page and then click on the Widget Inspector in 
the Inspector palette. Check either the Title or the Caption checkbox (or both) to transform the Image 
into an Image Widget. One or the other must be checked for the image to become a widget, though. 
Decide if you want the widget background to be visible or not. You will probably have to revisit the 
Wrapping Inspector - make sure that you have the widget selected and not just the image.

Note: If you turn an image into a widget, it will appear in the sidebar in portrait view - if you just place 
an image on a page, it will appear in landscape view, but it won’t appear in the sidebar in portrait 
view.

Widget Tips: 
✦ You cannot add a hyperlink in text within a widget by using the Inspector.
✦ You cannot see how most of the widgets work until you Preview them on an iPad.
✦ Whatever words you type in for a title or caption will automatically be reflected in the Accessibility 

Description in the Inspector.
✦ You can choose to have the widgets operate only in full view when tapped and not within the page 

at all.
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More Widgets
There is an online widget wizard called ClassWidgets. www.classwidgets.com/. Follow the 
instructions for each widget and download it. It will be downloaded as a .zip file. Double-click the zip 
file and it will extract the .wdgt file. Simply drag that file onto your iBooks page and change the 
placeholder text in the widget. 

Some widgets to choose from:
✦Sliding Puzzle – Upload an image, and a sliding puzzle widget will 
be created for you.
✦Interactive Timeline – This widget wizard takes the most planning. 
You can create awesome timelines with text and pictures. I found it 
best to download the images you want to use into a folder on your 
desktop in the planning stages, and even write the narrative in a 
TextEdit document to copy and paste into the widget. Images will be 
resized by the widget to fit the dimensions of an iPad in landscape 
mode: 1024X600, so select images as close to that size for the best 
view on the iPad.
✦Google Maps – Find a location on a Google map and copy the link 
to the map. The widget will show the map on your page and it can 
even be zoomed in or out and panned.

Other widgets available with (hopefully) more to come:
✦ Twitter feed
✦ YouTube
✦ Vimeo
✦ Polling

Publishing or Exporting
Take the time to go through your book in both portrait and landscape views and make sure that all the 
interactive elements are working as you intend them to. 
The landscape view is where most of the design work is. This is the view where all the interactive 
elements work at their best and where the book will look the best on an iPad. The viewer swipes 
horizontally to view the pages of the book.

The portrait view is the view that focuses on the text of the book, and the images and interactive 
elements are reduced in size and placed on the left side of the page. The viewer swipes vertically to 
navigate the pages. Check the portrait view page by page after you have designed your book in 
landscape view. There can be some spacing issues in that view. You may need to make some of the 
text smaller to fit the view. 
You can make formatting changes in portrait view that will not affect things in landscape view, but you 
you make content changes, like line spacing or spelling correction, those changes will occur in both 
views. If your layout is only good in landscape, you can disable portrait entirely by checking the box in 
the Document Inspector (Document tab).
Check the table of contents and the glossary, too. Oh - and don’t forget to proofread!
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Before you can think about publishing, you’ll need to preview your book on an iPad to make sure 
everything is displaying properly. 
✦ Make sure you have upgraded to iBooks 2.0 on your iPad. 
✦ Connect the iPad to your computer with the USB cord. 
✦ Open iBooks on your iPad.
✦ In Author, click the Preview icon in the toolbar.
The file will download to your iPad. 
I’m assuming that you will plan to export your book and share the file with you colleagues and 
students, but you can publish your book to iTunes. Submitting your book for publishing in the iTunes 
bookstore is complex. Review “Learn more about publishing to the iBookstore” found as a link in the 
Publish button in the toolbar (The help app will open). Apple also has an iBooks Author Support 
website with more information. 

You can export your book in other formats instead of publishing. The iBooks format allows you to 
export the book in iBooks format that you can drag to Books in iTunes and transfer to an iPad. You 
can also email the file to someone, and if they read their email on the iPad, they can tap the attached 
file and it will open in the iBooks app.
Exporting in PDF is also possible, although the interactive media might not work as expected.
The book can also be exported as a text file.

TRANSFERRING IBOOKS TO YOUR IPAD

Open iTunes and click on the Books section of the Library. 

You can go to File > Add to 
library… or simply drag the 
iBooks file into iTunes. 

Sync to your iPad.
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WEB RESOURCES:

ePUB Standards:
International Digital Publishing Forum

iBooks Author:
Apple 
iBooks Author

iBooks App for iPad

iBooks Author Gallery

Dashboard Widget Tutorial

iBooks Author Support

eBooks
Peachpit - Meet iBooks Author

O’Reilly - Publishing with iBooks Author

Websites
Hands-On With iBooks Author: eBook Authoring Made Easy

IBooks Author - Apple Introduces Easy eBooks with One Big Condition

How iBooks Author Stacks up to the Competition

iBooks Author Themes for Sale

Tutorials
Mac 20 Questions videos on YouTube

Using the Interactive Review Widget on YouTube

Creating Interactive Widgets for iBooks Author - (highly technical)
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